US Rapid, Debit Card & Virtual Card payments are currently delayed and may only be processed the next business day.
Incident Report for SpritzFinance
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 16:12 UTC
Identified
The issue has been identified and a fix is being implemented, usual payment processing times will resume on the 12th of November, by EOD.
Posted Nov 11, 2024 - 23:48 UTC
Investigating
We are currently investigating this issue.
Posted Nov 11, 2024 - 07:06 UTC
This incident affected: RTP Payments (US) and Off-ramp to Debit Card (US).